recipe bioconductor-egsea

This package implements the Ensemble of Gene Set Enrichment Analyses (EGSEA) method for gene set testing.

Homepage

https://bioconductor.org/packages/3.9/bioc/html/EGSEA.html

License

GPL-3

Recipe

/bioconductor-egsea/meta.yaml

Links

biotools: egsea

package bioconductor-egsea

(downloads) docker_bioconductor-egsea

Versions

1.10.0-0, 1.8.0-0, 1.6.0-0

Depends bioconductor-annotationdbi

>=1.44.0,<1.45.0

Depends bioconductor-biobase

>=2.42.0,<2.43.0

Depends bioconductor-edger

>=3.24.0,<3.25.0

Depends bioconductor-egseadata

>=1.10.0,<1.11.0

Depends bioconductor-gage

>=2.32.0,<2.33.0

Depends bioconductor-glimma

>=1.10.0,<1.11.0

Depends bioconductor-globaltest

>=5.36.0,<5.37.0

Depends bioconductor-gsva

>=1.30.0,<1.31.0

Depends bioconductor-limma

>=3.38.0,<3.39.0

Depends bioconductor-org.hs.eg.db

>=3.7.0,<3.8.0

Depends bioconductor-org.mm.eg.db

>=3.7.0,<3.8.0

Depends bioconductor-org.rn.eg.db

>=3.7.0,<3.8.0

Depends bioconductor-padog

>=1.24.0,<1.25.0

Depends bioconductor-pathview

>=1.22.0,<1.23.0

Depends bioconductor-safe

>=3.22.0,<3.23.0

Depends bioconductor-topgo

>=2.34.0,<2.35.0

Depends r-base

>=3.5.1,<3.5.2.0a0

Depends r-dt

Depends r-ggplot2

>=1.0.0

Depends r-gplots

>=2.14.2

Depends r-htmlutils

>=0.1.5

Depends r-htmlwidgets

Depends r-hwriter

>=1.2.2

Depends r-metap

Depends r-plotly

Depends r-rcolorbrewer

Depends r-stringi

>=0.5.0

Requirements

Installation

With an activated Bioconda channel (see 2. Set up channels), install with:

conda install bioconductor-egsea

and update with:

conda update bioconductor-egsea

or use the docker container:

docker pull quay.io/biocontainers/bioconductor-egsea:<tag>

(see bioconductor-egsea/tags for valid values for <tag>)